Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

using a midi controller to control the deluge synth engine causes issues

0
mpiecorampiecora United StatesPosts: 29

When I use a midi controller to control the synths in the Deluge the velocity of the notes causes the deluge's audio to crackle and distort. It happened on 3 different midi controllers, with headphones and external out. If I turn the velocity up on notes to the around the max it causes the same problem with only a few notes being triggered. Also noticed turning the reverb up to around the max on a group of 10 or more notes causes the audio to fizzle out completely.

Tagged:

Comments

  • 1
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 775

    You simply need to turn down the tracks volumes a good bit :)

    What's happening is, the Deluge's default velocity of the pads is 64 (hopefully we'll get a setting option for that soon in an update) and when using the midi controllers the velocity usually goes much higher, so the Deluge starts clipping internally when set to the default volumes of the presets.

    ~ Distinguished Delugate (▀̿Ĺ̯▀̿ ̿)

  • 0
    The user and all related content has been deleted.
  • 0
    mpiecorampiecora United StatesPosts: 29

    @Icoustik said:
    You simply need to turn down the tracks volumes a good bit :)

    What's happening is, the Deluge's default velocity of the pads is 64 (hopefully we'll get a setting option for that soon in an update) and when using the midi controllers the velocity usually goes much higher, so the Deluge starts clipping internally when set to the default volumes of the presets.

    @alien_brain said:
    turn it doooowwwwwn theres plenty of resolution. proper gain staging can make a massive difference in depth and color of your mix. you can go from no dynamic range to proper dynamic range and then squash with a limiter if you need that big sound. of course we dont get limiters on the deluge until... well we dont know exactly

    Thanks guys. Turning the track volume down doesn't change the clipping, just volume in which I hear the clipping. I think the default velocity that it receives is set too high.

  • 0
    The user and all related content has been deleted.
  • 0
    mpiecorampiecora United StatesPosts: 29

    @alien_brain said:
    you might have to turn the sample level down instead of the track level

    It's only a problem with the synth engine though :(

  • 0
    The user and all related content has been deleted.
  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 775

    Every time this has happened to me, it went away when turning down the master vol of the track or the osc volumes.
    If it doesn't, maybe something ain't right

    ~ Distinguished Delugate (▀̿Ĺ̯▀̿ ̿)

  • 0
    mpiecorampiecora United StatesPosts: 29

    @alien_brain said:
    are you using 24 bit version?

    You referring to the OS?

  • 0
    mpiecorampiecora United StatesPosts: 29

    @Icoustik said:
    Every time this has happened to me, it went away when turning down the master vol of the track or the osc volumes.
    If it doesn't, maybe something ain't right

    I'll try this, thanks again guys.

  • 0
    The user and all related content has been deleted.
  • 0
    mpiecorampiecora United StatesPosts: 29

    @alien_brain said:

    @mpiecora said:

    @alien_brain said:
    are you using 24 bit version?

    You referring to the OS?

    no, the adventure kid waveforms

    Oh, I am talking about the subractive synth engine.

  • 0
    The user and all related content has been deleted.
  • 0
    SamSam WellingtonModerator, Staff Posts: 160

    Hey @mpiecora! Thought I should just mention that I've let Rohan know about this and he's going to look into it. I'll update this if he finds anything. If the issue develops any more, or you'd like to send us synth/song files, feel free to email me @ sam.carswell@synthstrom.com :smile:

  • 0
    mpiecorampiecora United StatesPosts: 29

    @Sam said:
    Hey @mpiecora! Thought I should just mention that I've let Rohan know about this and he's going to look into it. I'll update this if he finds anything. If the issue develops any more, or you'd like to send us synth/song files, feel free to email me @ sam.carswell@synthstrom.com :smile:

    Oh, very cool! Thank you!

  • 0
    GrischaGrischa GermanyPosts: 2

    I think the problem still exist and if i turn down the volume on the oscillator,
    then playing on the external keyboard is ok but on the internal pad playing is much to quiet.
    Grischa

  • 0
    punchedoutpunchedout United StatesPosts: 29
    edited March 2019

    I'm also experiencing a similar artifact that I have not been able to pin point, but this thread seems similar. I'll do more testing tomorrow specifically on the velocity front or by turning down the OSC's.

    Post edited by punchedout on
  • 0
    punchedoutpunchedout United StatesPosts: 29

    Just bumping this because I did further testing and it is still an issue on 2.1.1

    I have some synth files for comparison if requested.

  • 0
    VondragonnogginVondragonnoggin California, USAPosts: 190

    They are up to 2.1.3 now

  • 0
    punchedoutpunchedout United StatesPosts: 29
    edited March 2019

    I did not notice this originally. Thank you!! Still after the update to 2.1.3 the issue persists...

    Only happens with polyphony through external midi controller near max velocity. Most noticeable when you strike the notes with full velocity. Makes every preset unusable by default until I reduce the volume of the OSC's. I have not determined the threshold yet for how much I need to reduce the value.

    Please resolve the fundamental issue or cap the OSC's so that this does not occur. I don't think I'm doing anything special as these are the stock presets that came with the device and I have only changed one parameter to resolve the issue.

    Post edited by punchedout on
  • 0

    @punchedout said:
    I did not notice this originally. Thank you!! Still after the update to 2.1.3 the issue persists...

    Only happens with polyphony through external midi controller near max velocity. Most noticeable when you strike the notes with full velocity. Makes every preset unusable by default until I reduce the volume of the OSC's. I have not determined the threshold yet for how much I need to reduce the value.

    Please resolve the fundamental issue or cap the OSC's so that this does not occur. I don't think I'm doing anything special as these are the stock presets that came with the device and I have only changed one parameter to resolve the issue.

    Was searching to make sure I wasn't the only one with this. Noticed it last night quite a bit since I was just messing around going through all of my sounds. Happens with subtractive synth, external input, generally with polyphony. Sounds like it might be expected but just wanted to throw my hat into the ring about the issue. I know this topics last message was a year ago but it's the 2nd and 3rd result on google when looking for the issue.

Sign In or Register to comment.