Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

freezes crash since oled retro fit

0
TobarTobar FrancePosts: 3

I am experiencing a lot of crash/freeze since the oled retro fit; nothing that i can reproduce, and it's not batterie related (i have tryed everything). am i the only one? sadly for me my deluge is unusable for live cession, crashes happens very fast.. is there a new firmware update coming soon that will fix that? before the oled retro fit that was fine; is it related to my sd card content? why with the new oled screen?

Comments

  • 0
    milkformycoconutmilkformycoconut GermanyBeta Tester Posts: 31

    Join Deluge discord community and raise this issue there. I am experiencing more freezing then on some previous fw.

  • 0
    rezareza los angelesModerator, Beta Tester Posts: 618

    what FW does your OLED have? the last official OLED is v4.1.3 found here: https://synthstrom.com/product/deluge/#downloads

    there is also currently a v4.1.4-beta going on, you would have to sign up for beta to receive it, see here: https://forums.synthstrom.com/discussion/3443/how-to-be-involved-in-beta-testing#latest

    if we don't know what actions you are doing when crashes happen, the harder it will be to diagnose. i would recommend filming yourself using it for a long session so everything is captured on camera.

  • 0
    Distant_CometsDistant_Comets Brooklyn, New YorkPosts: 1

    I'm also experiencing a LOT of crashes using the OLED retrofit and 4.1.3. I bought my unit used and immediately sent it to be retrofit so I have no experience with it prior to this and no way to compare before and after.

    What I've been doing so far is building out some folders for my synths and kits. I've downloaded some, and the previous owner sent it on with some. The use case that is causing the crashes most frequently is quite straightforward: navigating the folders and loading new patches.

    Specifically I:

    • Turn on the unit, and usually am taken to the first folder and patch that's available: arps/038 vapor arp.
    • I hit load+synth to start navigating the folder structure
    • I select a folder and load to go into that folder
    • I hit the piano button to get the iso keyboard
    • I listen to patches, play around, and then scroll through the patches and select the next one
    • Inevitably I eventually get the loading screen and the machine locks up.

    I used to code so I started thinking like a program and attempted the following fixes before reaching out:

    • Deleted all the .asd files in my sample directories - some of my samples came from ableton and I figured maybe their analysis files were the problem
    • I denested my folder structure as much as I could, figuring the sample library file locations were getting too deep or the synth xml files were getting too large because of the length of the individual references
    • I used deluge commander to make sure the synths and kits were connected to the underlyign samples properly

    So far, no luck.

    As a total noob to the Deluge, are their basic dos and dont's for organizing the folders and files on my SD card? Are there good and bad SD cards? What are some other troubleshooting basics I can look at? And then, of course, I've seen some mention of new stability problems with the retrofits. Is this common?

    One last point, I have largely seen these issues on battery but ALSO have had them occur plugged in.

    Thanks!

  • 1
    rezareza los angelesModerator, Beta Tester Posts: 618
    edited October 2023

    hey @Distant_Comets
    big folder structures shouldn't be an issue, so denesting shouldn't be necessary.

    maybe some specs on your current SD card could be useful. brand, sd speed type, GB size, how it's formatted, allocation size (32kb is best), and also how filled up it is. could be worth backing up the whole SD card then reformatting it and putting the content back in?

    faster SD cards do have some benefit, mostly with multisamples loading. but it shouldn't freeze like you mention.

    i would honestly suggest signing up for the official beta, from there you'll receive the beta firmware download. there's a chance that the issue is resolved in the beta

    Post edited by reza on
  • 0
    MuzkaMuzka Northern Ireland Posts: 1

    Hi

    Since sending mine for the uk retrofit it is constantly crashing and my battery wont charge any more. Have tried updating firmware and trying the community firmware but it’s still crashing and unusable.

    It worked fine before and don’t think I ever experienced a crash.

    If it’s not a firmware issue could there be something wrong internally?

    Thanks

  • 0
    alfadeoalfadeo germanyPosts: 9

    @Muzka same here. constant flashing green/yellow if on usb power but not starting at all with battery only. i'm going to open it now and take a look

  • 0
    alfadeoalfadeo germanyPosts: 9

    ok that was easy. the plug on the negative pole was bended. adjusting this fixed the issue for me.

Sign In or Register to comment.