Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

MIDI velocity issues (I already posted this elsewhere, but I think this is the best place)

0
WillWill Middle of NowHere, CanadaPosts: 236

I am using my Deluge with the new Novation Launchpad X controller.
I had to try a few MIDI/USB hosts to find one that worked, (ended up with the Kensington MIDI/USB host MkII).

Most of the functions work, and the Launchpad can be customized using their computer software - which has been very quick and easy.

PROBLEM: When controlling the Deluge externally, the velocity coming in, seems to be very high value.
**The sounds are considerably louder than when just playing the Deluge from its' own buttons.
**

I've tried different settings within the Launchpad, but even with the Lowest velocity curve, some of the sounds emanating from the Deluge actually distort.

Very frustrating.

Does anyone have any insights as how to modify, limit or customize the velocity curve - on either device?

I use this in my set up without a computer, so I need something 'standalone'

Thankful for any insights.

Will

Canada

Comments

  • 1
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    You probably just need to turn down the clip level. The default value is 64, considerably less than the output of most controllers. In the settings menu you can change the default to be closer to what your average playing velocity is. This will make playing the Deluge‘s buttons match your launchpad playing. You will just likely need to readjust for headroom.

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Too_Mere said:
    You probably just need to turn down the clip level. The default value is 64, considerably less than the output of most controllers. In the settings menu you can change the default to be closer to what your average playing velocity is. This will make playing the Deluge‘s buttons match your launchpad playing. You will just likely need to readjust for headroom.

    Where are you suggesting that I turn down the 'clip level'?

    I realize that there is a default velocity level, but I haven't been able to find anywhere on the Launchpad to do this, and I'm not aware of any Global setting like this on the Deluge. Thanks for your time

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963

    @Will said:
    Where are you suggesting that I turn down the 'clip level'?

    I realize that there is a default velocity level, but I haven't been able to find anywhere on the Launchpad to do this, and I'm not aware of any Global setting like this on the Deluge. Thanks for your time

    The Deluge default velocity setting: Settings menu > DEFAult > VELOcity

    Set the default velocity to your liking (personally I use 127), then compensate by turning down the clip volumes of all the clips, to avoid internal clipping.
    I.e. readjusting for headroom as Too_Mere mentioned.
    Alternatively, simply turn down affect-entire song volume in song view, which is an easier shortcut.
    The only slight downside of this shortcut being that if/when you want to record an audio clip set to the OUTPut source (internal resampling), you'll need to turn its clip volume level up to compensate for what you turned down on the song volume if you want the levels to match :)

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

  • 1
    WillWill Middle of NowHere, CanadaPosts: 236

    Thanks, can't wait to try this..........I appreciate you taking the time to assist me in this.....
    ...respect.....

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Icoustik said:

    @Will said:
    Where are you suggesting that I turn down the 'clip level'?

    I realize that there is a default velocity level, but I haven't been able to find anywhere on the Launchpad to do this, and I'm not aware of any Global setting like this on the Deluge. Thanks for your time

    The Deluge default velocity setting: Settings menu > DEFAult > VELOcity

    Set the default velocity to your liking (personally I use 127), then compensate by turning down the clip volumes of all the clips, to avoid internal clipping.
    I.e. readjusting for headroom as Too_Mere mentioned.
    Alternatively, simply turn down affect-entire song volume in song view, which is an easier shortcut.
    The only slight downside of this shortcut being that if/when you want to record an audio clip set to the OUTPut source (internal resampling), you'll need to turn its clip volume level up to compensate for what you turned down on the song volume if you want the levels to match :)

    What I was hoping to do, was to set a MAXIMUM velocity within the Deluge, or the output of the Launchpad, so that I still have velocity sensitivity - it would suck to loose the dynamics, (unless I can figure that out, I might as well be just playing from the Deluge - I added the Launchpad, so I'd have dynamics)

  • 0
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    There’s not a way I know to set a maximum on either device. It could be with a DAW in between the LP and Deluge.

    Also the solutions Icoustik and I are suggesting match volumes and prevent clipping but do also preserve velocity dynamics from the LP.

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Too_Mere said:
    There’s not a way I know to set a maximum on either device. It could be with a DAW in between the LP and Deluge.

    Also the solutions Icoustik and I are suggesting match volumes and prevent clipping but do also preserve velocity dynamics from the LP.

    OK thanks for those insights.....Much appreciated

  • 0
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    No problem 👍🏼

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    ;0)

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Icoustik said:

    @Will said:
    Where are you suggesting that I turn down the 'clip level'?

    I realize that there is a default velocity level, but I haven't been able to find anywhere on the Launchpad to do this, and I'm not aware of any Global setting like this on the Deluge. Thanks for your time

    The Deluge default velocity setting: Settings menu > DEFAult > VELOcity

    Set the default velocity to your liking (personally I use 127), then compensate by turning down the clip volumes of all the clips, to avoid internal clipping.
    I.e. readjusting for headroom as Too_Mere mentioned.
    Alternatively, simply turn down affect-entire song volume in song view, which is an easier shortcut.
    The only slight downside of this shortcut being that if/when you want to record an audio clip set to the OUTPut source (internal resampling), you'll need to turn its clip volume level up to compensate for what you turned down on the song volume if you want the levels to match :)

    What I'm struggling with is that - even if I reduce the Clip Volumes on everything I'm working on, that doesn't affect all the dozens of custom presets I've created with custom samples, kits, etc. I guess it may be the only solution, and I AM grateful for your insights, I just want to resolve things so that my workflow is not compromised in the future. I also would like to be able to revisit older compositions and not have to tweak every clip in order to play presets with an external controller - no big deal.......small issues compared with other things in life.....

    Thanks again....

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963
    edited May 2021

    @Will said:
    What I'm struggling with is that - even if I reduce the Clip Volumes on everything I'm working on, that doesn't affect all the dozens of custom presets I've created with custom samples, kits, etc. I guess it may be the only solution, and I AM grateful for your insights, I just want to resolve things so that my workflow is not compromised in the future. I also would like to be able to revisit older compositions and not have to tweak every clip in order to play presets with an external controller - no big deal.......small issues compared with other things in life.....

    Thanks again....

    This is exactly why I think turning down Affect-entire volume in song view is a much better solution for you (and turning up the master volume knob to compensate) :)

    Post edited by Icoustik on

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Icoustik said:

    @Will said:
    What I'm struggling with is that - even if I reduce the Clip Volumes on everything I'm working on, that doesn't affect all the dozens of custom presets I've created with custom samples, kits, etc. I guess it may be the only solution, and I AM grateful for your insights, I just want to resolve things so that my workflow is not compromised in the future. I also would like to be able to revisit older compositions and not have to tweak every clip in order to play presets with an external controller - no big deal.......small issues compared with other things in life.....

    Thanks again....

    This is exactly why I think turning down Affect-entire volume in song view is a much better solution for you (and turning up the master volume knob to compensate) :)

    Awesome - I'll try it tonight........

    Here's another little trip you might like: (you'll hear the distortion I'm talking about)

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Icoustik said:

    @Will said:
    What I'm struggling with is that - even if I reduce the Clip Volumes on everything I'm working on, that doesn't affect all the dozens of custom presets I've created with custom samples, kits, etc. I guess it may be the only solution, and I AM grateful for your insights, I just want to resolve things so that my workflow is not compromised in the future. I also would like to be able to revisit older compositions and not have to tweak every clip in order to play presets with an external controller - no big deal.......small issues compared with other things in life.....

    Thanks again....

    This is exactly why I think turning down Affect-entire volume in song view is a much better solution for you (and turning up the master volume knob to compensate) :)

    YESSSS!!! That (affect entire) worked perfectly. I had expected that I'd be able to adjust some MIDI filter parameter as a default Global setting inside the Deluge....but this solves the problem for me.'

    Feeling a mega dose of gratitude for your patience and valuable insights........................(you've earned some serious Karmic Coupons for sticking with me through this, bro!)

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963

    @Will said:
    YESSSS!!! That (affect entire) worked perfectly. I had expected that I'd be able to adjust some MIDI filter parameter as a default Global setting inside the Deluge....but this solves the problem for me.'

    Feeling a mega dose of gratitude for your patience and valuable insights........................(you've earned some serious Karmic Coupons for sticking with me through this, bro!)

    Fantastic! That makes me happy indeed :) My pleasure, Earth bro.
    We are cells in the same brain (•◡•๑)

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

  • 0
    WillWill Middle of NowHere, CanadaPosts: 236

    @Icoustik said:

    @Will said:
    YESSSS!!! That (affect entire) worked perfectly. I had expected that I'd be able to adjust some MIDI filter parameter as a default Global setting inside the Deluge....but this solves the problem for me.'

    Feeling a mega dose of gratitude for your patience and valuable insights........................(you've earned some serious Karmic Coupons for sticking with me through this, bro!)

    Fantastic! That makes me happy indeed :) My pleasure, Earth bro.
    We are cells in the same brain (•◡•๑)

    Then, I guess we are 'Cell Mates'?

    Hope things are going ok for you during all this international drama........
    Peace, Love and Understanding.....

    w

    ;0)

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

Sign In or Register to comment.