Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Deluge LED yellow - not turning green when fully charged

0
wolfrenegadewolfrenegade brisbaneBeta Tester Posts: 11

Hey all,

First time charging my new Deluge.

I'm using a mains boss guitar pedal charger (12v - centre negative).

I left it overnight and the LED is still yellow whilst still plugged into the mains? Shouldn't it be green to indicate fully charged?

Thanks,

Comments

  • 0
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    A new battery can take a VERY long time to charge the first time. As long as it’s staying solid yellow (not flashing green and yellow) I would just keep it charging a while longer.

  • 0
    wolfrenegadewolfrenegade brisbaneBeta Tester Posts: 11

    Please ignore, checked the manual and the LED should be orange when plugged into mains and USB. When I removed the mains supply from the deluge the green light comes on very quickly then dissappears which I assume means 'fully charged'

  • 0
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    That’s not quite correct. When fully charged it should stay green while still plugged into power.

  • 0
    wolfrenegadewolfrenegade brisbaneBeta Tester Posts: 11

    Oh really? I’ll charge it for longer but it’s already had a 10 he charge

  • 0
    Too_MereToo_Mere Chicago, IL, USABeta Tester, Mentor Posts: 755

    I think my new battery took around 12+ hours to fully charge. Just keep it plugged as long as possible and it should get there eventually.
    After the first time it should charge more quickly.

    If it never goes green I’d consider replacing the battery and/or filling out this troubleshooting form:
    https://docs.google.com/forms/d/e/1FAIpQLSeTP-eDaaDOmU4-WRXcVhQIoIBd8bkLC_Up4_Lt1RbYZXA-xQ/viewform

Sign In or Register to comment.