Please familiarise yourself with the forum rules & guidelines

Deluge firmware V3.1.2 released

6
rohanrohan Staff Posts: 173

Firmware V3.1.2 is now released, containing several bug fixes.

Download it here.

Fixes include:
* Fixed bug which could occur for very high resolution songs when playing synced to a clock input, and made more likely as CPU use gets higher
* Fixed problem with part-way-through playback beginning (with <> + PLAY) of samples in kits in CUT or LOOP mode
* Fixed rare crash when hosting some very specific USB MIDI devices
* Fixed - a crash could occur when editing the "reverse" parameter for a multi-sampled instrument where any of the multi-sampled items did not contain a sample

Installation
To install the update, place the .bin file onto your SD card, ensure there are no other .bin files on there, put the card back into your Deluge, and then hold down the shift button while powering on. A spinning animation will display, and the firmware will be permanently installed.

Please take this opportunity to back up the data from your SD card while it's in your computer. Any storage technology can fail, and we want your work to be safe regardless.

Comments

  • 0
    supchikovsupchikov Posts: 9

    Perfect :)

  • 0
    timmy0808timmy0808 United StatesPosts: 4

    I'm having problems with my Deluge after installing. The onboard synth controls don't seem to function correctly. I have a patch that I used the cutoff manually and now when I use the knob I am not getting any type of change. Also the side chain isn't working and I am having connection issues with my keyboard. The onboard synth seems to work with my external keyboard for several patches then it just stops receiving data from the external keyboard.
    Anyone else having problems like these?

  • 0
    MDLAMDLA FrancePosts: 1

    It’s working! Thank u. If it’s possible, maybe it’s ever been asked by someone, but truncate fonction, might be helpful in sampling mode. I did have some freeze, on clip view while the clip is playing, on 3.1.1 I’ll let I u know, waths’up on the new version.

  • 0
    MendMusicMendMusic RomaniaPosts: 5

    Hey guys, please note that in this update there is a new save error that doesn't allows you to save a song.
    Downgraded the firmware and it's ok now so it's probably something in this new one.
    More detailed:
    Made a sequence within a kit, and tried to save it, the screen wrote error but started to do that snake effect like it's saving but it didn't stop unless I pressed back/undo.
    Tried by opening a new project and still it did the same

  • 0
    mattfwaltersmattfwalters Vancouver, BC, CanadaPosts: 2

    I had a straight-up crash last night running this firmware. I was creating a new synth patch while a few tracks were playing, and was playing around with loading multisamples (specifically: I prepared a bunch of Samples From Mars for easier use with the Deluge), just browsing, loading multi, playing around a bit, and repeat on Osc 1 of the patch. I think the crash was triggered by a keypress on the USB controller I had connected to the Deluge (i.e. attempting to start playback of the just-loaded multisample) and it just locked up. I should note that I wasn't able to get the USB controller working again after restarting the unit, but I didn't want to troubleshoot it so I just switched to the MIDI in and carried on.

    I'm pretty new to the Deluge - I probably have 12 or so total hours with it - so I don't know if this is an issue introduced with 3.1.2 or not.

  • 0
    rohanrohan Staff Posts: 173

    Apologies for not seeing these comments reporting potential bugs sooner. We've actually just released V3.1.3, though I'm unsure whether this will have addressed these particular findings.

    @timmy0808 have you got a particular song file which demonstrates the issue, and perhaps behaves differently in two different firmware versions? If so, please send it to me at rohan@synthstrom.com

    @MendMusic that sounds strange, I have a suspicion that it could be a problem with the SD card, but it does seem strange that you didn't get the same problem after re-downgrading to an earlier firmware version. Perhaps you could try upgrading to V3.1.3, and try a new SD card, and see if you have any luck being able to save songs again?

    @mattfwalters is that MIDI controller still refusing to work with the Deluge via USB? What MIDI controller is it - and does it have the option of powering the controller, say with a 9V, in addition to it being plugged into the Deluge via USB? Is it possible at all to replicate the crash you experienced by doing the same thing? And last question - I don't suppose you were listening on the Deluge's internal speaker? It draws a bit of current when a sound plays, so I'm interested in ruling out a power issue.

    You're all welcome to email me directly at rohan@synthstrom.com to carry on these conversations, and I'll do my best to help.

Sign In or Register to comment.