Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Distorted presets when triggering with a velocity-sensitive external controller

0
synchrosystemsynchrosystem Greater Los AngelesPosts: 6

Hey all,

I have an Arturia keyboard controller hooked up to the Deluge and am attempting to play synth presets and multisampled instruments I have added. Both synth presets and multisampled instruments are clipping/distorting unless I play the keys very lightly, making this simple idea of playing sounds with an external controller all but impossible.

I've gathered from older posts addressing this issue that the track level can be turned down (seems like clipping still occurs, only at a lower volume!) or a velocity setting can be changed for individual notes.

Given those posts are two years old, has there now been any firmware etc update that has resolved this issue?

What's the best current way to avoid/workaround this issue?

Thanks

Comments

  • 0
    mopocomopoco EuropePosts: 3
    • add a note in clip view and adjust its velocity to max. Hold note + turn left right.
    • Each consecutive note will have the last adjusted velocity, in this case max.
    • Add some more notes in the pitch range you are going to record later on. Can be just a four on the floor simple thingie that covers the pitch range and play Back.
    • Now adjust your sound at that max velocity so that your happy, in this case without distortion. Again, Keep in mind that pitch range matters and deeper notes tend to produce louder dynamics and will therefore drive everything that comes after the oscillators/samples.
    • When your’re done testing with max velocity notes, carry on with your work.
    • Think about saving your testing max velocity sequence. Should save you time :)
  • 1
    MatthewGeorgeMatthewGeorge Cologne, GermanyBeta Tester Posts: 243

    You have to turn the OSC volumes down. Also use note as a mod destination on the volume. Negative modulation will make bass notes louder and positive higher notes will be louder.

  • 0
    hexagon5unhexagon5un MunichBeta Tester Posts: 112

    It's really easy to overdrive the Deluge early in the chain, and it sounds bad. What @MatthewGeorge said is right: drop the OSC volumes until it doesn't distort when you're hammering it.

    I was playing around with the Adventure Kid waveforms as a source for instance, and b/c they're full-range samples, you really need to have the OSC volumes down around 25 instead of 50, and maybe even lower if you're adding a lot of velocity-sensitive dynamics or stacking up voices.

    Oddly enough, the internal (subtractive synth) waveforms run just fine at 50, which I don't fully understand.

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963

    @hexagon5un
    Clip volume plays a part as well in addition to the OSC volumes. Even Affect entire song volume level, which would be last in chain - they all end up in and through the DAC (digital-to-analog converter) on their way out, which is where the internal clipping happens. As long as the DAC isn't overloaded by volume due to any of those settings, it'll be fine.
    Regarding the internal synth compared to samples, its basically all dependent on the level of the source material.
    Samples will typically be 'hotter' than the internal synth's waves.

    A sound generally just needs to have its clip level/ osc level set according to the max velocity that will be used, and the number of stacked voices, if using chords/ layering.

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

  • 0
    pfrfpfrf ca, u.s.a.Posts: 165

    You can also turn down the velocity sensitivity of the preset-
    press shift + velocity mod source and choose something less than 50.
    I think the problem stems from the decision to make 64 the default velocity. That's theoretically understandable but in real world use, when playing keys, default velocity seems to be somewhere between 80 and 100. It's different for every player and every keyboard but I'd venture to say that very few people play so lightly as to consistently trigger values below 64. 64 is the median, the mean is probably closer to 84.

  • 0
    hexagon5unhexagon5un MunichBeta Tester Posts: 112

    @Icoustik said:
    @hexagon5un
    Clip volume plays a part as well in addition to the OSC volumes. ...they all end up in and through the DAC (digital-to-analog converter) on their way out, which is where the internal clipping happens. As long as the DAC isn't overloaded by volume due to any of those settings, it'll be fine.

    Interesting! I thought it was bit-depth distortion in the processing, but you're saying that it's overdriving the output DAC? I guess that makes sense, since turning down the output further downstream still fixes the problem...

    Does this mean that we realy want a (digital) compressor/limiter effect before the DAC? That would solve that problem once and for all, although in a brute-force kinda way.

    Quasi-aside: do you know what bit-depth the Deluge processes to internally? A lot of the values in the XML files are 32 bits. That would leave tons of headroom on 16-bit WAV files.

  • 0
    IcoustikIcoustik NorwayModerator, Beta Tester, Mentor Posts: 963

    Limiter could be a solution, but it would indeed be much more brute force than turning down one's levels, and it would take additional CPU as well, etc. I dunno. Not what I would choose, but not my decision either :)

    The Deluge's native bit depth and samplerate you mean? That's 44.1kHz 16/24bit

    ~ Distinguished Delugate ᕕ( ◎_◎)ᕗ

Sign In or Register to comment.