Please familiarise yourself with the forum rules & guidelines

Deluge firmware V3.0.4 released

11
rohanrohan Staff Posts: 173

Deluge firmware V3.0.4 is now released - a minor bugfix release.

Download it here.

Fixes include:
* Fixed bug relating to arming audio clips to solo or stop soloing
* Fixed possible unexpected behaviour when unmuting a track in arranger if playback had been begun from part-way through the arrangement
* Fixed - clearing the contents of a MIDI clip would reset all MIDI CC params to value 64, when it should have just cleared automation

Installation
To install the update, place the .bin file onto your SD card, ensure there are no other .bin files on there, put the card back into your Deluge, and then hold down the shift button while powering on. A spinning animation will display, and the firmware will be permanently installed.

Please take this opportunity to back up the data from your SD card while it's in your computer. Any storage technology can fail, and we want your work to be safe regardless.

Comments

  • 0
    MatthewGeorgeMatthewGeorge Cologne, GermanyPosts: 229

    Sweet as!
    Thanks Rohan.

  • 0
    KomplexKomplex Soundform RecordingsPosts: 8

    Excellent!

  • 0
    chvadchvad Brooklyn, NYPosts: 35

    Thanks as always man!!! You da' best!

    www.controlledbleeding.com | www.chvad.com

  • 1

    Thanks for excellent support. Waiting wavetables...

  • 0
    AmiganutAmiganut AustraliaPosts: 3

    thank you still loving it

  • 0
    mbangmbang Gothenburg, SwedenPosts: 61

    Awesome Rohan + team, thanks for the effort! <3

  • 0
    udelugeudeluge germanyPosts: 52

    Im sure I was able to mute an audio track in 3.0.3 that was monitoring the line in. now I can still hear the line in when the track is muted.

    facebook is evil

  • 0
    rohanrohan Staff Posts: 173

    @udeluge if you mute it in arranger view, it'll mute its monitored input.

  • 0
    udelugeudeluge germanyPosts: 52
    edited March 3

    But not in song view, where I work the most time and as it did in older FW versions. I'm not sure why it is necessary that mute doesn't work in song view for a audio clip track that monitors the line in.

    Post edited by udeluge on

    facebook is evil

  • 0
    OdoSendaidokaiOdoSendaidokai BerlinPosts: 298
    edited March 16

    Got a problem from time to time, that on a cloned clip the synth is broken. When i clone the cloned clip again it is still broken. The original clip still works. Changing the synth preset didn't work either.
    If there is something written in memory or temp the routine could be buggy? I didn't save this song, nor did I load it. It was from scratch and the deluge was turned on 10 minutes before it happened.

    Video and Sound
    https://mytube.madzel.de/videos/watch/33b25ff1-e565-477a-8ef6-7edde9656dc1

    Post edited by OdoSendaidokai on
  • -1
    DannyL96DannyL96 GermanyPosts: 1

    Hey guys. I just registered in this forum and i dont know how to start a new topic. So I have to write here to get helped. I´ve got 2 questions:
    1. How to start a new discussion / topic?
    2. If I want to record live-notes into the sequenzer, it doesnt work. Notes only get saved on the first step of every bar?? HEEEELP please!

  • 0
    IcoustikIcoustik NorwayModerator Posts: 674

    @DannyL96 said:
    Hey guys. I just registered in this forum and i dont know how to start a new topic. So I have to write here to get helped. I´ve got 2 questions:
    1. How to start a new discussion / topic?
    2. If I want to record live-notes into the sequenzer, it doesnt work. Notes only get saved on the first step of every bar?? HEEEELP please!

    1. Go to the Category you want to start a thread in, then click the New button up top
    2. Firstly, are you're on the latest firmware, i.e. 3.0.4 which is in this thread?
  • 0
    ListenListen LondonPosts: 3

    Hey guys, I've downloaded the software onto a new SD card.
    When I have tried to update , I keep seeing "FOLD" so I can't get any synths, programs etc

  • 0
    ListenListen LondonPosts: 3

    @Listen said:
    Hey guys, I've downloaded the software onto a new SD card.
    When I have tried to update , I keep seeing "FOLD" so I can't get any synths, programs etc

    I sorted it :)

    however the names of the synth etc are not showing ...

  • 0
    rastro2rastro2 United StatesPosts: 2

    What did you do to sort out the "FOLD" error?

  • 0
    udelugeudeluge germanyPosts: 52

    The FOLDer error can be a problem with the filesystem of the sd card. Have you tried a other card with the factory default content only?

    https://s3.us-east-2.amazonaws.com/synthstrom-audible-deluge/Deluge+V2p1p0+factory+card+contents.zip

    facebook is evil

Sign In or Register to comment.