Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Kits with CV or MIDI can't be used in other tracks.

0
UntilledSoundUntilledSound Seattle, WAPosts: 2
edited June 2019 in General Discussion

Not sure if I should put this in "Software Suggestions" but it seems like a bug to me. Here's my issue:

I'm trying to create some control templates for my Eurorack system. I mainly use my deluge as a control source for my rack. When creating these tracks, I've been using some arrangement of the pre-set kits, using samples. So I don't have to hook up the entire system every time I want to edit and create these control tracks.

I just got done making a large number of these kit tracks, and my hope was that I could simply create a "Control Kit" and turn the sample kits into the control Kit and then be done. However this never seems to work.

Here's my example: I created a bunch of tracks using Kit 999. It's just 10 drum samples I'm using to make sure it works. I made a whole bunch of these tracks. Then when I was done. I went to one of these tracks (Lets call it track A) and edited the kit so that every drum track was either a CV or MIDI output. I saved this kit track, once again as 999.

Here's the baffling part, when I go to the next track (Track B ), and I change it to Kit 000, then back to Kit 999 again. In theory this should change it to the CV and MIDI mapping that I did for the first track, but it doesn't. It stays with the sample sounds from before. What's even weirder is if I go back to track A and move the kit to 000 and back to 999, it KEEPS the CV and MIDI mappings I laid out. So it's like there's two instances of track 999, one is mappings and one is samples, and no matter what I do it stays that way. Even power cycling leaves me with the exact same scenario. I've also tried saving the kit in track A as different numbers. (998, 997, 996) And it's the same behavior. Track A has a CV and MIDI Kit, while Track B has a sample kit, both labeled the same number.

I have indeed updated my deluge to the latest firmware, and I couldn't find this issue anywhere else in the forums. Please let me know if I missed it. Otherwise, am I doing something wrong or is this a bug?

Many thanks,

Post edited by UntilledSound on

Comments

  • 0
    rohanrohan Staff Posts: 179

    Hi!

    Just trying to picture what you're doing - when you say "when I go to the next track", do you mean the next song?

    When you mention moving the kit to 000 and back to 999, could you try saving and reloading your song in between these steps (obviously save a backup or save it as a different number), and see if that helps?

  • 0
    UntilledSoundUntilledSound Seattle, WAPosts: 2

    Hi Rohan,

    Sorry I don't mean next song, I mean the next track. Same song, different tracks. I have two tracks using the same kit, but If I change the kit in one so that it has CV and MIDI mappings, I can never change the kit in the other track to match it. They'll have the same number and everything, but one will have the CV and MIDI mappings and the other will not. I have tried saving the song but that doesn't work. I can save the song. Turn off the Deluge, turn it back on and it still acts the same way. Where one track will have midi mappings, the other will have samples, and both will have the exact same number.

    I can make a video of this if it helps.

  • 0
    duelinmarkersduelinmarkers Austin TX USPosts: 136

    This sounds like behavior I've seen for all edits when multiple tracks use the same sound. I suspect it has nothing to do with CV or MIDI.

Sign In or Register to comment.