Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

SOLVED: SD card problems after updating

justindavidowjustindavidow Winnipeg, CanadaPosts: 16
edited January 2019 in Deluge Help

===== UPDATE ======

Issue was solved!

===== / UPDATE =====

Hi Folks!

Hope I'm alone; yet also hope I'm not alone! :cold_sweat:

Updated my Deluge last night to 2.1; and ever since I'm unable to save to the SD card.

Loading stuff songs / samples is no problem; the card is not in write protect mode (as far as I can tell; I'm able to insert it into a computer and write to the card without a problem.

Powering on the Deluge; putting down any note; and pressing "save" simply blinks "FAIL" on the screen.

Also unable to record; when trying to record something; I get the overall light dim; then the new "bot-toP" window; and if I continue past there the record light flashes briefly and the main screen then returns to full brightness brightness (but never records anything)

I'll try a new SD card when I get home today; but I've formatted this card and have absolutely no problem writing to it (stock 16GB Verbatim car that came with the deluge) getting ~21MB/s writing 8+GB files at a time; so I doubt it's a card problem)

Anyone else have any SD card issues after updating? Anyone have any ideas of what I can check?

Post edited by justindavidow on


  • 0
    justindavidowjustindavidow Winnipeg, CanadaPosts: 16

    Well; tried 4 different SD cards now; all seem to exhibit the same symptoms.

    Formatted each using different computers; different operating systems; different format methods; all of them yield cards that I can DD a file to / from without a problem (or benchmark the cards in any other practical way) yet none of them can be written to in the Deluge.

    Thinking it might be something about the latest firmware; I down-graded to 2.0.3; but the problem persists. I cannot save anything on the deluge; and I really don't have any further troubleshooting steps to take here..

    To get back to "stock" I'm:

    • removing the SD card
    • Inserting the SD card into a computer
    • non-quick formatting the SD card (tried quick + non-quick)
    • dumping the contents of the "Entire V2.1.0 factory SD card contents (332MB)" onto the card
    • Ejecting the card from the computer
    • inserting the SD card into the Deluge
    • Powering on the Deluge

    And nothing I do appears to let me save anything. I can load songs; switch synths; load kits; create new kits while loading samples; etc. Everything but saving appears to work. When I try to save; I get the screen flashing "FAIL" as noted above.

    Anyone have any ideas on troubleshooting things?

  • 1
    rohanrohan Staff Posts: 590

    Hi Justin, so sorry to hear! It won't be anything to do with the firmware. I'm emailing you right now about possible solutions.

  • 0
    justindavidowjustindavidow Winnipeg, CanadaPosts: 16

    Thanks @rohan; your pointer led me to the issue and I repaired the problem!

    For anyone interested; my specific issue was not software at all; was just a one-in-a-million hardware issue that was easy to solve (for someone technically inclined)

    (short version : there was a chemical reaction between some silicone and the specific connector used for the SD Card; just by chance the silicone happened to foul the write-protect lever arm tip due to proximity, and removing the SD Card to perform the 2.1 update, enough oxidization of the contact occurred that the unit was unable to get out of write-protect mode)

    Back to making music on this wonderful device! :smiley:

  • 0
    maltinmaltin United StatesPosts: 1

    Would you have any specific instructions for how you corrected the issue? I just bought a 2018 deluge and it is having the same issue.


  • 0
    SalaendoInterCitySalaendoInterCity DresdenPosts: 10

    Would also be interested in how u resolve the issue. Could be the same on my unit.

  • 0
    pedrocorrea1020pedrocorrea1020 USPosts: 1
    edited January 2021

    @rohan @justindavidow

    Hello Guys,

    I possibly have this same issue were I cannot write. If I push the sd card to the right amount of pressure I am able to save a song. Is this write-protect lever arm fix something I could do home? or do I need to send my deluge for service.

    @maltin @SalaendoInterCity any updates or fixes on this?

    Appreciate your help guys.

    Post edited by pedrocorrea1020 on
Sign In or Register to comment.