Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Song . XML structure totaly wrecked

0
dondadadondada DeutschlandPosts: 6

Dear Users,

I've destroyed most of my songs after i've changed the position of a new samplefolder to another place in the folderstructure, wich i have uloaded bevore into my sd card. So after a first look, the naming was totaly wrong also the endings of the filename. inside there is wired signs.. so my question is , does someone had the same problem, if yes how can i revert this to have my arranged songs back ? :-(

thanks in advance

dada

Comments

  • 0
    pbolgerpbolger ChristchurchPosts: 61

    Wired signs?
    First thing: take a backup of what you have on the card now - save it as a compressed file.
    Then, decompress a copy of your backup and take a look through the files. It's all xml and shouldn't be too hard to fix. You just need to work out what has been changed, and it's probably something like an illegal path name (like, a blank space in a directory name which has been written into the song sample paths).
    Let us know when you have more information. And try to be specific.

  • 0
    amiga909amiga909 Central EuropePosts: 1,067
    edited September 2019

    backup, yes. you say, you moved a folder on the sd card? if you can undo that change (move back the folder where it was) it might be fine. if not, as pbolger said it takes some manual XML editing to fix as the Deluge has no “find missing samples” function.
    is the “wired sign” a “~” ?

    Post edited by amiga909 on
  • 0
    dondadadondada DeutschlandPosts: 6
    edited September 2019

    thx , for answering, i've taken a closer look into several files, one xml file has only rectangles displaying in one line..

    Post edited by dondada on
  • 0
    OdoSendaidokaiOdoSendaidokai BerlinPosts: 306

    Is your SD card broken?

  • 0
    amiga909amiga909 Central EuropePosts: 1,067

    yeah that sounds like corrupt xml files. "only rectangles displaying in one line." you are opening the xml file in a text editor (like Notepad)? do not open it with Word or something similar.

Sign In or Register to comment.