Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Deluge firmware V2.1.4 released

rohanrohan Staff Posts: 179

This is another minor bugfix update from us, which we recommend you install.

Download Deluge firmware V2.1.4


  • Fixed bug which could cause tempo to lag or slow down in rare cases when MIDI tracks used
  • Minor improvement to the way in which existing automation is overwritten with newly recorded automation for MIDI parameters
  • Fixed rare bug where tempo could suddenly become extremely fast and SYNCED LED would light up
  • Fixed potential crash involving arranger track-instances which have been set to display keyboard view
  • Fixed - when modulating an envelope’s sustain level from another modulation source, the sound could cut out unpleasantly
  • Fixed bug where you couldn’t arm a song section while turning a gold knob
  • Fixed rare crash when loading song while another plays

To install the update, place the .bin file onto your SD card, ensure there are no other .bin files on there, put the card back into your Deluge, and then hold down the shift button while powering on. A spinning animation will display, and the firmware will be permanently installed.

We recommend you take the opportunity to back up the contents of your SD card while it's in your computer.


  • 1
    pfrfpfrf ca, u.s.a.Posts: 165

    Thank you Rohan!

  • 0
    sarmismsarmism ManchesterPosts: 11

    Brill. I got caught with the midi slowdown bug a while back when trying to sync my Critter/Guitari ETC. Thanks!

  • 0
    Rian78Rian78 USAPosts: 17

    Thanks again!
    I have had the crash on loading a few times.

  • 0
    BonatiBonati NYCPosts: 8

    Thanks for your work Rohan!

  • 0
    OldBuildingOldBuilding USAPosts: 6
    edited June 2019

    I think I was able to successfully update to 2.1.4. I checked the system firm settings after rebooting.

    I just received my Deluge on Friday, and played it all weekend, so I know it's working.

    I tried upgrading to a 256Gb sd card tonight (San Disk micro sd card with a converter so that it fits in the card slot; formatted as FAT32) which worked for the firmware update.

    Now, when trying the following from clip mode...

    Load a new synth, (shift+synth) I see "NONE".
    Load a new kit (shift+kit) I see "FOLD"
    When I try shift+type -> "SAMP" -> click the select knob -> "0A" -> turn the select knob -> "FOLD".

    Fold is the only option and I can't select into it or browse up the tree from there. I'm assuming it's an error, but I haven't found any reference to FOLD here, or online.

    Post edited by OldBuilding on
  • 0
    OldBuildingOldBuilding USAPosts: 6

    Update: it’s also happening with the sd card that the deluge shipped with.

  • 0
    pfrfpfrf ca, u.s.a.Posts: 165

    Are the included folders (KITS, SAMPLES, SONGS, SYNTHS) on your sd card as well?

  • 0
    OldBuildingOldBuilding USAPosts: 6

    I believe so. I didn’t do anything except copy the contents to a new card and then add the firmware file at the root.

    What should the directory structure for system required files be?

    What are the rules about directory structure for my custom files and samples?

    Does the name of my custom dir matter?

    Does the volume name of the sd card matter?

  • 0
    pfrfpfrf ca, u.s.a.Posts: 165

    The folders I mentioned are at the root. I’ve put my custom samples in a folder called USER inside the SAMPLES folder. I don’t believe the Deluge OS is picky about what you name your own folders or the folder structure of your own samples as long as you don’t change it later. I keep it short to ease reading on the display.

    You’re going to have to email Rohan on this one. Customer support is excellent.

  • 0
    OldBuildingOldBuilding USAPosts: 6


  • 0
    OldBuildingOldBuilding USAPosts: 6

    I think I know what happened. I only copied over the SAMPLES directory to the root of the new SD card. I found the root directories on the card that shipped with the Deluge and am fixing stuff now.

  • 0
    pfrfpfrf ca, u.s.a.Posts: 165

    I’m happy to read you’ve got a possible solution. I hope it works out.

Sign In or Register to comment.