Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

can't write to SD card

bat_cancerbat_cancer Baltimore Posts: 14

hey all
So I put the SD card in my mac and downloaded the .bin file but I can't drag it on because it says I have only reading permission not writing. The physical lock is not on the card. See my screen cap


  • 0
    keppecokeppeco Beta Tester Posts: 10

    if you drag those folders off the card, maybe you can reformat it and then add the files back to it?

    I also saw a lot of results on google when searching "sd card you can only read mac" (seems like a hardware issue), so maybe those solutions would be helpful as well

  • 0
    SamSam WellingtonModerator, Staff Posts: 160

    Hi @bat_cancer! Have you tried fiddling with the lock switch close to a middle position, as shown in this video:

  • 1
    bat_cancerbat_cancer Baltimore Posts: 14
    Hey all I was concerned that reformatting might affect the cards interaction with the software. I found a PC and did it.
  • 0
    rpc9943rpc9943 New York usaBeta Tester, Mentor Posts: 175

    I had this issue a few weeks ago and just had to restart my computer, but then it worked! was windows 10.

Sign In or Register to comment.