Please familiarise yourself with the forum, including policy on feature requests, rules & guidelines

Deluge firmware V4.1.3 released (currently for OLED only)

9
rohanrohan Staff Posts: 590

Deluge firmware V4.1.3 is out now! This is a "minor" firmware update containing mostly fixes relating to OLED functionality. It is currently for the OLED Deluge only. (More on the classic "numeric" Deluge below.)

--- Download V4.1.3 (OLED) here ---

Fixes include:
* Fixed a memory fragmentation problem that was slowing down performance and causing audio/voice dropouts when many audio files (e.g. multisampled instruments) had been loaded since power-on.
* Fixed audio dropouts or glitching when reading a folder’s contents (e.g. when changing presets).
* Fixed crash or strange behaviour with some sample names, particularly those containing underscores.
* Loading a sample as “BASIC” now resets that oscillator’s transpose.
* File browser on OLED Delue now wraps around at the start and end, like on the numeric Deluge.
* Fixed behaviour of editing note velocity or probability/iteration-dependence on OLED Deluge.
* Fixed misleading visual glitch occurring after user deletes a file.
* Fixed problem accessing “CLONE” function for presets.
* Fixed obscure crash under very specific circumstances in waveform view.

Installation

To install the update, place the .bin file onto your SD card, ensure there are no other .bin files on there, put the card back into your Deluge, and then hold down the shift button while powering on. A spinning animation will display, and the firmware will be permanently installed.

Please take this opportunity to back up the data from your SD card while it's in your computer. Any storage technology can fail, and we want your work to be safe regardless.

Future firmware updates for classic "numeric" Deluge

In the near future, we'll begin releasing every firmware number/version as two separate builds - one for the OLED Deluge, and one for the numeric. We have this setup functioning great here at the Synthstrom office, but these numeric-Deluge builds are just not quite ready to release yet. Possibly next time?

These two different types of build are from the same, latest codebase, which will continue to support both kinds of Deluge. This ensures that all future fixes and features which aren't 100% reliant on the OLED display will be available for Deluges old and new. This will also allow song files to be exchanged between both types of Deluge. (Currently, the numeric Deluge can't read files written by the OLED Deluge's newer V4.1.x firmware.)

«1

Comments

  • 0
    sven_blobsven_blob France Beta Tester Posts: 153

    :) thx a lot Rohan ! 🙏🙏🙏

  • 1
    Bay_MudBay_Mud OntarioBeta Tester Posts: 119

    Great news! Any idea when the 7-segment units will get the fixes for the memory issues? Happy to hop into beta mode to test anything.

  • 1
    i8urbraini8urbrain Los AngelesPosts: 4

    Thanks for the continued support

  • 0
    jensgjensg Berlin, GermanyBeta Tester Posts: 297

    @Bay_Mud said:
    Great news! Any idea when the 7-segment units will get the fixes for the memory issues? Happy to hop into beta mode to test anything.

    +1

  • 0
    tinmountainaudiotinmountainaudio PortlandPosts: 2

    Thanks Rohan! Excited about the directory wraparound and the dropouts fix for scrolling through sounds. I've noticed a pretty big dropout problem with overdubbing audio since updating though that I didn't notice before, though - a few different times, I've tried getting a session going with a simple drum part, one or two internal engine synth loops, and then recording 4-6 consecutive vocal harmony audio overdubs on top of each other, and by the 3rd or 4th overdub things start dropping out like crazy, including previous overdubs. Drum sounds get super clipped and whole synth parts drop out. Things kinda come back when I stop the overdub process, but it still seems like the unit is dropout-prone at that point until I shut it off and start a new song. Anyone else notice anything like this and/or do you have any ideas about a cause?

  • 0
    MiniDXMiniDX FrancePosts: 2

    Thank you !

  • 1
    WiegrafWiegraf Beta Tester Posts: 9

    Thanks! I ran into almost all the issues you fixed on a pretty regular basis, so this makes my life much easier!!

  • 0
    rohanrohan Staff Posts: 590

    Hey @tinmountainaudio thanks for letting me know about the trouble you're having. I tried following the steps you listed, but wasn't able to replicate the behaviour. I wonder what we're doing differently - are you recording stereo audio maybe? Is the Deluge playing synced to an external clock?

  • 0
    CADCAD Auckland, NZPosts: 15
    edited February 2023

    Hi @rohan, I've had a pretty dramatic fail on my update. I powered off my Deluge, took the SD out and followed the install instructions as I've done for every update thus far. I put the SD card in, held shift and tried to turn it on and I got nothing, no lights no anything.

    please disregard. It seems my deluge just ran out of power and the charging cable wasn't plugged in correctly. Very silly of me. Sorry for the bother!

    Actually I do seem to be in a bit of trouble.. The Deluge won't turn on at all in any capacity any more. When attached to a myvolt charger it initially flashes orange and green and then sits at a steady orange. Is there anything I can do on my end to fix/trouble shoot this further or am I going to have to send it in?

    Post edited by CAD on
  • 0
    Bay_MudBay_Mud OntarioBeta Tester Posts: 119

    @CAD said:
    Hi @rohan, I've had a pretty dramatic fail on my update. I powered off my Deluge, took the SD out and followed the install instructions as I've done for every update thus far. I put the SD card in, held shift and tried to turn it on and I got nothing, no lights no anything.

    please disregard. It seems my deluge just ran out of power and the charging cable wasn't plugged in correctly. Very silly of me. Sorry for the bother!

    Actually I do seem to be in a bit of trouble.. The Deluge won't turn on at all in any capacity any more. When attached to a myvolt charger it initially flashes orange and green and then sits at a steady orange. Is there anything I can do on my end to fix/trouble shoot this further or am I going to have to send it in?

    Is it possible your battery may have come dislodged (did it get knocked or anything)? Might be worth opening up the side and making sure the battery is sitting well between the pins. I dropped my Deluge and the battery came just loose enough that it would no longer hold a charge or turn on. Easy fix, at least, if that's all it is.

  • 0
    CADCAD Auckland, NZPosts: 15
    edited February 2023

    Solved! Thanks to Too_Mere "This may have happened if the Deluge was interrupted while still updating the firmware. Unlike with the old screen, the OLED currently has no update animation for the screen. So when you update it remains blank until the update is finished.
    I would recommend trying the update process once more by holding shift while powering on and then let it be for a minute or so. Hopefully that should let the process finish and you should be good to go after that."

    Post edited by CAD on
  • 1
    FrenchFrench United StatesPosts: 10

    Thank you so much for addressing the browser not wrapping around, that was driving me nuts!

  • 0
    EdREdR Dallas TX USAPosts: 51

    My delivery's a week out now. I can't WAIT! Woo-hooo!

  • 0
    TobarTobar FrancePosts: 3

    hey, i am experiencing a lot of crash recently, since the oled retro fit, even after this update; it seems to happens only when the Deluge is synced to an external clock (syntakt master, deluge slave). it happens randomly, while searching for a new sound or adding a new track; one crash every 2 hours max.. before the oled retro fit that was fine.. does anyone have the same issue?

  • 0
    TobarTobar FrancePosts: 3

    @Tobar said:
    hey, i am experiencing a lot of crash recently, since the oled retro fit, even after this update; it seems to happens only when the Deluge is synced to an external clock (syntakt master, deluge slave). it happens randomly, while searching for a new sound or adding a new track; one crash every 2 hours max.. before the oled retro fit that was fine.. does anyone have the same issue?

    Edit : it happens when no ext sync too..

  • 0
    AntsnowAntsnow Ventura, CA, USAPosts: 5

    Am I able to revert to a prev firmware with OLED? this firmware doesnt give CC feedback from external device.

    What I'm doing: I like to have a back <-> forth connection between my Deepmind and deluge. I used to be able to set CC on deluge and the led lights would show feedback if i moved something on the Deepmind (ie cutoff / cc29) but now it does not.

    I checked to make sure the Deepmind is sending CC via a monitor app on my computer and it is.

  • 1
    jensgjensg Berlin, GermanyBeta Tester Posts: 297
    edited March 2023

    Any ETA on the fw becoming available to non oled users?

    Post edited by jensg on
  • -2
    LawnbearLawnbear Indiana Summer months/ New Mexico Winter monthsPosts: 5

    i didn't know there was a oled version i guess i have the old numeric version maybe do a a update

  • -3
    LawnbearLawnbear Indiana Summer months/ New Mexico Winter monthsPosts: 5

    plus i find it kind of tough to do update on a Sd card most synths do a usb firmware though there sites

  • -3
    LawnbearLawnbear Indiana Summer months/ New Mexico Winter monthsPosts: 5

    and its kind of tough to open a Bin Compressed file Zip file i think Synthstrom need to do a compatible update on firmware

  • 3
    Bay_MudBay_Mud OntarioBeta Tester Posts: 119

    @Lawnbear said:
    and its kind of tough to open a Bin Compressed file Zip file i think Synthstrom need to do a compatible update on firmware

    You don't have to do anything with the BIN file except put it in the root folder of your card. Very easy.

  • 0
    jensgjensg Berlin, GermanyBeta Tester Posts: 297

    @Bay_Mud said:

    @Lawnbear said:
    and its kind of tough to open a Bin Compressed file Zip file i think Synthstrom need to do a compatible update on firmware

    You don't have to do anything with the BIN file except put it in the root folder of your card. Very easy.

    True, it’s easy. And the same for a lot of other gear.

  • 0
    LawnbearLawnbear Indiana Summer months/ New Mexico Winter monthsPosts: 5

    i try it see if it works thank you for response

  • 0
    djAziddjAzid AmsterdamPosts: 199

    Fixed audio dropouts or glitching when reading a folder’s contents (e.g. when changing presets).

    This still happens often when browsing synths or just by switching from a synth to a kit.

  • 0
    tinmountainaudiotinmountainaudio PortlandPosts: 2

    @rohan said:
    Hey @tinmountainaudio thanks for letting me know about the trouble you're having. I tried following the steps you listed, but wasn't able to replicate the behaviour. I wonder what we're doing differently - are you recording stereo audio maybe? Is the Deluge playing synced to an external clock?

    Hey @rohan thanks for the reply! I’m not recording stereo audio or syncing from an external device, though I am using the deluge as the master clock to sync a couple other devices. I haven’t had this happen since the first week or so of use of the new firmware, so maybe it was a corrupted session or something (I have a couple template sessions I often start from, so it’s possible that I had started from one that just had some kind of issue, maybe?). I’ll keep you posted - all’s well for now

  • 0
    AntsnowAntsnow Ventura, CA, USAPosts: 5

    @Tobar said:

    @Tobar said:
    hey, i am experiencing a lot of crash recently, since the oled retro fit, even after this update; it seems to happens only when the Deluge is synced to an external clock (syntakt master, deluge slave). it happens randomly, while searching for a new sound or adding a new track; one crash every 2 hours max.. before the oled retro fit that was fine.. does anyone have the same issue?

    Edit : it happens when no ext sync too..

    Yes, I am having this issue now too. Really hoping these bugs are worked out soon. Messing with my workflow a lot.

  • 1
    jensgjensg Berlin, GermanyBeta Tester Posts: 297

    @Antsnow said:

    @Tobar said:

    @Tobar said:
    hey, i am experiencing a lot of crash recently, since the oled retro fit, even after this update; it seems to happens only when the Deluge is synced to an external clock (syntakt master, deluge slave). it happens randomly, while searching for a new sound or adding a new track; one crash every 2 hours max.. before the oled retro fit that was fine.. does anyone have the same issue?

    Edit : it happens when no ext sync too..

    Yes, I am having this issue now too. Really hoping these bugs are worked out soon. Messing with my workflow a lot.

    I hope a 7seg update will come soon too fixing the 🐛 / crashes / glitches.

  • 0
    bnhrschbnhrsch GermanyBeta Tester Posts: 7

    Thank you for this update and all the work you put into the deluge. Stil having stability issues but I am sure you guys will figure it out.

  • 0
    AbortRetryFailAbortRetryFail FloridaBeta Tester Posts: 61

    @Antsnow said:
    Am I able to revert to a prev firmware with OLED? this firmware doesnt give CC feedback from external device.

    I noticed it seems to be eating pitch bend on MIDI clips now too.

  • 3
    SynthStudioSynthStudio Fort Collins, ColoradoPosts: 31

    Is there some ‘official’ place to watch for the latest stable FW updates? It’s kind of confusing just watching this forums because posts seem to jump around based on activity.

Sign In or Register to comment.