Please familiarise yourself with the forum rules & guidelines

Harpsichord multisample - stop 1, stop 2, lute stop, and combinations

1
MetamereMetamere United StatesPosts: 12

I put together a multisample set for the Deluge from a harpsichord sampling project that was posted online here. I had to do a bit of batch editing of the filenames and of the tags using EndlessWAV, but it ended up working well.
EDIT:
Since the Deluge can't trigger a sound on the release of a key, they end up sounding a bit unnatural unless the notes play the maximum duration. I included one sound set up the other way as an example (mode = Cut instead of Once).
I set up various combinations of the three stops they provided by assigning one sample to OSC1 and the other to OSC2. For the lute combinations I reduced the level of the other sounds to make the lute sound stand out more. In order to get this working, you will need to place the synths in the SYNTH folder, and place the Multisamples folder (which contains the three multisample sets) in the SAMPLES folder. I also included a copy of the license stipulations and information on the sample origins in the folders. Please look it over and follow their reasonable requests.

Here is a link to a 94 MB .7z archive, and a 135 MB .zip archive if you aren't able to extract a 7zip archive (it may not work properly on the Deluge when using the default Mac archive tool.

They load fairly quickly, although they don't cover the entirety of a modern piano keyboard. They cover 58 notes, from G#0 to F5 (roughly 5.5 octaves), which is a very usable range, and are tuned to a modern 440 instead of the traditional 415. They are really fun to play with a midi keyboard, and I've already used them in a couple of songs. Enjoy.

(here are the original questions related to the thread below)
I noticed that their sample collection has separate samples for the attack and for the release of each key. I see that there's a way to account for that in software synths like Kontakt, but is there a way to handle that in the Deluge or in other hardware synths? I couldn't find any reference to that. It sounds fine as is with the mode set to "once" (simulating sustain on), but in other modes it doesn't sound quite right when the note stops so abruptly when the key is released. It just doesn't sound like a real harpsichord. Also, to make it sound more realistic when using a midi keyboard, it would be best to be able to set the velocity to max by default. Is there a way to do that? Thanks in advance.

Post edited by Metamere on

Comments

  • 1
    IcoustikIcoustik NorwayModerator Posts: 674

    Provided you have the latest firmware installed, you can set the default velocity in the settings menu.
    DEFAult -> VELOcity

    No way to trigger samples upon release for now, and I haven't found a way to do it with extra midi fancyness either. I'm trying to make something happen with Midiflow (ios app)

  • 0
    MetamereMetamere United StatesPosts: 12
    edited July 16

    That's good to know, thanks. Although it seems that only affects the Deluge's pads, and a midi keyboard will still play them with varying velocity. Can I add a velocity tag to the sample name to force it to always play with a constant velocity?

    Okay, instead of playing a second sample upon release, is there a way to play two different samples when a pad or key is pressed? Like if I wanted to play two different stops on a harpsichord simultaneously? Or do I need to merge them into one sample on my PC in advance?

    Post edited by Metamere on
  • 1
    IcoustikIcoustik NorwayModerator Posts: 674

    @Metamere said:
    That's good to know, thanks. Although it seems that only affects the Deluge's pads, and a midi keyboard will still play them with varying velocity. Can I add a velocity tag to the sample name to force it to always play with a constant velocity?

    Okay, instead of playing a second sample upon release, is there a way to play two different samples when a pad or key is pressed? Like if I wanted to play two different stops on a harpsichord simultaneously? Or do I need to merge them into one sample on my PC in advance?

    To turn off a preset's velocity sensitivity, enter the Volume parameter (Master volume) of the clip in question, then enter the Velocity mod source that will be blinking to indicate the volume is patched to the velocity mod source.
    Turn the depth to 0.

    You can use OSC2 browse (to load separate sampleset to OSC2) :)

  • 0
    MetamereMetamere United StatesPosts: 12

    Okay cool, thanks. So it sounds like the velocity insensitivity is only set in the clip, not the synth preset? I couldn't quite get that working, but I'll figure it out eventually. I also couldn't figure out how to load the samples into OSC2 in the Deluge, but I was able to get them loaded by copying and pasting in the XML files. I'll figure out how to work that in the Deluge eventually too I guess. At least I know it can be done. The combined samples sound amazing, by the way. I made various combinations of the three stops. Once I get permission from the guy who created the samples I'll post them here.

  • 0
    IcoustikIcoustik NorwayModerator Posts: 674

    @Metamere said:
    Okay cool, thanks. So it sounds like the velocity insensitivity is only set in the clip, not the synth preset? I couldn't quite get that working, but I'll figure it out eventually. I also couldn't figure out how to load the samples into OSC2 in the Deluge, but I was able to get them loaded by copying and pasting in the XML files. I'll figure out how to work that in the Deluge eventually too I guess. At least I know it can be done. The combined samples sound amazing, by the way. I made various combinations of the three stops. Once I get permission from the guy who created the samples I'll post them here.

    The preset IS the clip, same thing. In the clip view of the preset, i.e. where the preset's sound parameters can be accessed, enter the mentioned Volume level parameter either via the grid shortcuts or the sound editor menu, in order to turn off the velocity>volume patching.

    Same with OSC2 loading - simplest is to use the OSC2 Browse shortcut (2nd column, third pad from the top).

    Hope you get to share it :)

  • 0
    MetamereMetamere United StatesPosts: 12

    Hey @Icoustik, thanks for all the help with this. It looks like the original creators probably aren't going to get back to me, so I'll assume it's all good since this is all otherwise following their terms. Would you please try downloading and giving the samples a test and let me know what you think? If it works for you and you think the quality is good enough then I'll edit the title and add the link to the first comment.

    https://drive.google.com/file/d/14z5Pqhzyj2eFqs29897OUUmsquFscmZ-/view?usp=sharing

  • 0
    n_Bn_B United StatesPosts: 5

    I was able to unarchive the file without trouble, but the format of the WAV files seems off. Deluge states "UnSu" and Audacity does not recognize the filetype. The XML files look great, though! Thank you for sharing your effort!

  • 0
    MetamereMetamere United StatesPosts: 12
    edited August 12

    Hey @n_B, thanks for testing it out. The files are supported since they work on my Deluge. Did you keep them in the Multisamples subfolder like I had set up? Hmm, you probably would've done that since that's how you had the TAL samples set up. Or could it be that you have an older firmware or something?

    Post edited by Metamere on
  • 0
    n_Bn_B United StatesPosts: 5

    Hi @Metamere! I think it's actually the WAVs. I am unable to play them with anything after unarchiving the .7z file and they appear to be binaries.

    Here's the result of file -I

    Petit-Italien-Luth-009--G#0.wav: application/octet-stream; charset=binary

    This is what a normal WAV looks like:

    BD2_Clean_Bobeats.wav: audio/x-wav; charset=binary

  • 0
    MetamereMetamere United StatesPosts: 12
    edited August 12

    Hey @n_B, thanks for the info. I can't seem to identify things in the way you did. I tried extracting the archive and they appear to be the same as before they were compressed. I wonder if it has to do with how you extracted the archive? If you aren't on Windows and used a different program maybe there was an issue. Here is a link to a .zip version of the archive, as well as a link to one of the .WAV files, uncompressed. Would you please check them and see if they have the same issue as before? Thanks.

    https://drive.google.com/file/d/17WhChBlCh_KErF7TTkX7jSYCABaRKGpE/view?usp=sharing
    https://drive.google.com/file/d/1V2xUeIgu9CdzzF1WieeV0b1STwcAWlpU/view?usp=sharing

    Post edited by Metamere on
  • 0
    n_Bn_B United StatesPosts: 5

    That was a success! It must be something related to the built in Archive tool on MacOS. I can confirm that the samples now play on the Deluge and sound beautiful. Thank you!

  • 1
    MetamereMetamere United StatesPosts: 12

    Hey @n_B, I'm glad it worked and you like it. You're very welcome. Thanks for testing it out. Sorry I didn't realize you were a different person than the other who was helping me earlier.

Sign In or Register to comment.