Please familiarise yourself with the forum rules & guidelines

Anyone else finding the MIDI sockets are very loose?

0

My MIDI cables don't seem to engage very positively with the sockets on the Deluge.
Anyone else finding this, or is it just my cables?

Best Answer

  • 0
    SamSam Wellington
    Answer ✓

    Hi @MoonWolf! Is it that the sockets themselves are loose/wobbly/moving or is it that MIDI cables don't seem to stay in place? If it's the first, send me an email at sam.carswell@synthstrom.com. If it's the second, maybe try a few different cables and post here again (and tag me) if you still have the issue with all of them :smile:

Answers

  • 0
    alien_brainalien_brain yer moms house

    i havent noticed

  • 0
    minigoatminigoat cincinnati ohio usa

    fine here

  • 0

    My midi cables actually are very difficult to insert into the deluge. Maybe it has to do with the brand.

    https://www.amazon.com/Monoprice-Cable-Plugs-3-Feet-108532/dp/B009GUP5SW

  • 1
    MoonWolfMoonWolf United Kingdom

    @Sam said:e
    Hi @MoonWolf! Is it that the sockets themselves are loose/wobbly/moving or is it that MIDI cables don't seem to stay in place? If it's the first, send me an email at sam.carswell@synthstrom.com. If it's the second, maybe try a few different cables and post here again (and tag me) if you still have the issue with all of them :smile:

    It's that the cables don't seem to stay in place.
    I have tried other cables, and they seem to be ok.
    It'll just be my (rather expensive) plugs that are the problem, then... :(

Sign In or Register to comment.