Please familiarise yourself with the forum rules & guidelines

Launch Control XL with Deluge MIDI Host isn't working

0

Hello,

I was just trying to get my Launch Control XL (LCXL) to work with my Deluge so that I can:
1) Use the Deluge as the MIDI host for the device
2) Use the LCXL knobs for effects on the Deluge
3) Send MIDI through from the LCXL to my Octatrack so that the faders controls track volume

My setup is:
1) Deluge plugged into a USB hub
2) Launch Control XL plugged in the same USB hub

When the launch control XL starts it just does the "waiting screen" where the lights go back and forth.

Has anyone been able to use the Launch Control XL with Deluge?

I am wondering if I'm missing a setting or something simple here.

Any and all help is greatly appreciated.

Thanks,
Brett

Comments

  • 0
    EddyEddy ColognePosts: 241

    what if direct connected without hub?

  • 0
    BrettBrett Posts: 39

    @Eddy said:
    what if direct connected without hub?

    Great question - I have to order a cable adapter to do that (note: already on order).
    Both device require type A USB connector.
    I did order up a female to female USB B adaptor to see if that will work.
    Once I have the answer for the direct connect, I will let you know!

    Overall, I would hope/expect that it would work through a hub.

    Thanks,
    Brett

  • 0
    p_watsp_wats TorontoPosts: 97

    @Brett said:

    @Eddy said:
    what if direct connected without hub?

    Great question - I have to order a cable adapter to do that (note: already on order).
    Both device require type A USB connector.
    I did order up a female to female USB B adaptor to see if that will work.
    Once I have the answer for the direct connect, I will let you know!

    Overall, I would hope/expect that it would work through a hub.

    Thanks,
    Brett

    My understanding is the current midi host implementation does not yet work with hubs, so you're best to try direct for now.

  • 0
    IcoustikIcoustik NorwayModerator Posts: 665

    Correct, no hubs currently :)

  • 0
    BrettBrett Posts: 39

    Hello,

    Summary: Direct connect did not work for me.

    A few more details and observations:
    1) When I do connect a hub, the Deluge seems to note it is a hub.
    2) Given the above, that hubs don't work, so as noted, it did not find the device.
    3) When directly connecting and powering on the Deluge I get "Unkn"
    4) the Launch Control XL device does go into a "normal" visual mode where it no longer has the "chasing" lights.
    5) When I tired to do the MIDI learn, it did not seem to work.

    Any other thoughts or suggestions I should try ?

    Thanks,
    Brett

  • 0
    IcoustikIcoustik NorwayModerator Posts: 665

    Launch Control XL doesn't currently work with Deluge's usb-midi hosting, due to the LCXL's weird usb driver.
    But when the Deluge becomes able to use hubs it will also be able to host devices better :)

    In the meantime, if you want to use the LCXL you'll need an external usb-midi host.

  • 0
    FalxFalx Posts: 1

    @Brett

    Hi, I was wondering if you tried the LCXL with the Deluge after firmware v3.1 update which included usb host capabilities?
    If so, does it work?

  • 0
    IcoustikIcoustik NorwayModerator Posts: 665

    @Falx said:
    @Brett

    Hi, I was wondering if you tried the LCXL with the Deluge after firmware v3.1 update which included usb host capabilities?
    If so, does it work?

    It works now!

Sign In or Register to comment.