Please familiarise yourself with the forum rules & guidelines

Sample playback issue with stretch

1

I might be doing something wrong but I'm not sure. I have a few different sample packs with melodic content in them in various keys. Black octopus and other things I've picked up off loopmasters. I've noticed that the deluge stretch mode creates noise artifacts in the sample even if it's at the same tempo with the key unaltered. So for instance I have a deep house piano loop at 120 bpm in A minor. I load it into a fresh kit. The default bpm on the deluge is 120 but I double checked to be sure. If I leave the sample playback mode to "cut" and play the sample it remains unaltered. Plays nice and smooth and it's in time. If I put it to stretch mode however all kinds of strange audio artifacts start showing up even though the bpm is still the original bpm( I imagine it has something to do with the time stretching algorithm similar to the way Ableton has different time stretching modes). Then you change the tempo or the pitch and of course it gets worse. Seems to be not as pronounced with drum loops but it's still noticeable.

So I guess I have two questions.
1) Is the situation I mentioned normal?
2) Is there a good way to work with melodic samples if you end up wanting to pitch a looped sample up or down to get it in key/tempo without the audio sounding really garbled?

Thanks

Comments

  • 0
    amiga909amiga909 Central EuropePosts: 912

    the note off event is crucial for stretch mode. maybe thats what u experience?
    both in synth and kit mode a stretch sample is stretched based on the note length.
    try recording via the audition pads: sounds different when played back.
    then again, try editing the sample end in the waveform view. gets me pretty rad granular fx. cant be automated yet sadly.

    for what u want to do: the sample sounds unchanged if you place a note on the root note (red) if in synth mode.
    the note has to be exactly as long as the sample length. u may need to edit the track length.

  • 0
    Mr_ForkMr_Fork North DakotaPosts: 37

    @amiga909 Yes that makes sense. The clip is 8 bars long at 120 and on the deluge I have a single note in a kit that spans 8 bars exactly. In cut mode it loops perfectly with no strange audio artifacts. There are no stutters at the end/beginning of the loop. Switching to stretch mode with the exact same note results in sound artifacts. I have also tried removing the note and making a new 8 bar note. I agree that playing with the speed or end point is great fun however all I'm trying to do is shift the pitch while keeping the bpm constant. While it allows me to do this the sound has so many artifacts that I can't really use it. I've tried with a number of samples and it's all the same.

  • 0
    Mr_ForkMr_Fork North DakotaPosts: 37

    I think I figured it out. Going to do some more testing. The sample packs that I am working with have the bpm mislabeled. Which is a little strange considering the producer of the sample pack. I threw the same sample into ableton and even though it's labeled 120, ableton is saying it is at 112.94 bpm. So started doing the same thing with the other samples in question and sure enough none of them are at 120 per ableton's auto detect. It's too bad the deluge doesn't have different stretch or "warp" modes. Maybe in the future. In the meantime I think I understand what is going on.

  • 0
    RblanchRblanch USAPosts: 4

    Did you ever figure this out? I am having the same problem. I am loading a vocal sample labeled 110 bpm with the metronome set to corresponding rate. When I switch from Cut Mode to Stretch Mode, it introduces clipping artifacts into the sound. I can play around with the sample length and eventually minimize the artifacts, but this takes a long time of trial-and-error to find a reasonable cut point. Then if I change the pitch or tempo, all the artifacts return.

    I wonder if this is some kind of rounding error with the time-stretch algorithm?

    I am able to recreate this with a simple sine wave. Using a new synth, set a single oscillator to sine wave, program C3 for one beat, then resample (using play-record, play-record to time it exactly). Create a new synth using that sample. Everything sounds fine as long as pitch/speed mode is linked, but when switching the mode to independent, all notes (except for the original C3) have clicking artifacts.

    Am I doing something wrong? While not noticeable with many of my samples, it is obvious with relatively pure tones making these samples unusable, short of re-pitching or re-timing the sample beforehand on a DAW.

  • 0
    normalmusicnormalmusic VancouverPosts: 3

    I'm having a similar problem with a melodic sample I'm trying to tempo-match. It has to play back about 10% faster to match BPM I'm using and if I try to use Stretch mode the audio quality of the sample suffers a lot (it's a vocal take so becomes very obvious). When doing a similar thing in Octatrack I notice no such distortion on the same sample. When using Cut mode, the sample sounds pristine, but of course falls out of tempo. Would love some pointers on how to minimize that...?

  • 1
    duelinmarkersduelinmarkers Austin TX USPosts: 108

    If dialing in the tempo and pitch you want has artifacts and you've tried both interpolation modes (but I think the default would be superior) then using some other software to make the adjustment on a computer may be your best option.

    You could experiment with compromising on tempo or pitch and setting the pitch/speed parameter to link the two, which should yield no time-stretch artifacts.

  • 0
    normalmusicnormalmusic VancouverPosts: 3

    Thanks - I finally settled on a solution that doesn't involve a computer, I'll just resample them as played by Octatrack straight into Deluge, at the correct BPM.

Sign In or Register to comment.