Please familiarise yourself with the forum rules & guidelines

Serious issues when using MIDI solutions Quadra Thru with Deluge!

1

Hi All,

We are transitioning our midi brain from Electribe 2S to Deluge and using our MIDI solutions Quadra Thru now seems dangerous!

Deluge midi controls Moog Minitaur, Minilogue and TR8 (so far).

The problem is that we encounter stuck notes issues every 30s (on both synths), random notes lost (on TR8) and late program changes :-(

This is our midi splitter: http://www.midisolutions.com/prodqth.htm (multivoltage)

Note that this splitter worked well with the Electribe 2s (apart some midi notes that were lost on the TR8) but I also understand that passive splitters can be unreliable with some hardware sequencers...

What should we do? Which midi splitter (4 outs enough) works 100% with deluge in your experience?

Thanks in advance for your help!

Comments

  • 0
    CandyGarageCandyGarage MontrealPosts: 8

    Is it just a question of choosing an active box vs passive? For ex., does the Kenton THRU-5 seem like a good solution (preventing all the issues listed above to happen)?

  • 0
    amiga909amiga909 Central EuropePosts: 1,063

    maybe you got a midi feedback loop? can lead to very strange effects.

  • 0
    karousinkarousin GermanyPosts: 3

    I have the same problem... did you find a solution?

  • 0
    VondragonnogginVondragonnoggin California, USAPosts: 190
    edited May 2019

    @CandyGarage said:
    Is it just a question of choosing an active box vs passive? For ex., does the Kenton THRU-5 seem like a good solution (preventing all the issues listed above to happen)?

    I have both boxes but never tried the Quadra Thru with my Deluge. It’s running off my MV8800 without any issues the last 5 years. Ive only used the Kenton THRU-5 with the Deluge. Even hang a midi to DIN Sync converter (Kenton) off one of the ports to sync my RE-303. No drops or weird timing issues.

    How long are your midi cable runs? Passive boxes start having issues with multiple long cable runs. I keep short cables on both setups but would definitely go all active if I had long cables and multiple runs of them.

    Post edited by Vondragonnoggin on
  • 2
    AntsnowAntsnow Ventura, CA, USAPosts: 1

    I know this is an old thread, but as a sort of new Deluge user I still scour the web for solutions here.

    After a few troubleshooting tests, I’ve determined that the Quadra Thru does not get enough power from the Deluge.

    I was having an issue getting my Blackbox to stay in sync with the Deluge and was on the verge of selling it before I found this out.

    My original midi signal flow was Deluge > Quadra Thru > Blackblox (as well as several other synths).

    In addition to the Blackbox falling entirely out of sync, there was some noticeable latency between the Deluge sequencer and the arpeggiators on my Deepmind & Hydrasynth.

    SOLUTION: The Deluge has no real issue syncing one synth via DIN MIDI, so I changed the signal flow to as follows: Deluge > Hydrasynth > Quadra Thru (via the Hydrasynth thru) > Blackbox, etc.

    After switching to this routing, the Quadra Thru is now getting adequate power from the Hydra and everything is in perfect sync!

    I would recommend this method to anyone who is having this issue and has a quality synth with a THRU port. Otherwise, buy a powered thru box.

Sign In or Register to comment.