Please familiarise yourself with the forum rules & guidelines

Deluge ignores learned cc-numbers

0
StromerStromer GermanyPosts: 47

I defined some midi-cc-numbers by pressing the learn button and sending controller values to the Deluge for different channels. Works fine as long as I don't reload the song. When reloading the song, which of course was saved after the learn process, everything was gone. I also saved each sound individual with the new cc-definitions but that didn't solved the problem.

Post edited by Stromer on

Comments

  • 0
    StromerStromer GermanyPosts: 47

    By the way. Why is in the song.xml a midichannel #0 defined?

  • 0
    StromerStromer GermanyPosts: 47
    edited March 13

    The problem seems to be very tricky. When reloading the song it sometimes works fine and other times the Deluge has this midi-cc-alzheimer. The same when turning the machine off. A short OFF sometimes makes no problem while a longer OFF causes definitely a problem with the learned midi-cc's. So it is not possible to work with the Deluge in an environment with other machines where the main control instance is a midi-box or software, sending midi-cc's. Would be really great if this problem could be fixed with the next update.

    Happy new year! :)

    Post edited by Stromer on
  • 0
    StromerStromer GermanyPosts: 47

    Problem solved. I erased all 'midiKnob' messages in the song xml, then I let the Deluge learn from scratch, that works. Midi channel #0 is channel #1. Deluge works internally from 0-15.

Sign In or Register to comment.